Back to overview
Degraded

Media malfunction due to Cloudflare Global Network outage

Nov 18 at 01:32pm EET
Affected services
Media storage

Resolved
Nov 18 at 05:27pm EET

Services have largely returned to normal, but we will continue to monitor the situation.

Created
Nov 18 at 01:32pm EET

The photos and other media on our instance are malfunctioning due to Cloudflare outage. Sorry about this, but there's nothing we can do on our end. Media is something we can’t easily self-host cost-efficiently, we're talking terabytes of data. Discussion: https://mementomori.social/@rolle/115571015419313731